Support Area

SobiPro club members with an active subscription are entitled to get ticket support in the support area. For our former club members we provide a free of charge forum to ask other members. If you need professional support with fast answers, feel free to join the club.


Update SobiPro and its applications to the most recent version before reporting a problem!

We are continously improving SobiPro and its applications, fixing bugs and making working with them more easy. Still we see that some users report problems for older versions. Mostly they are already fixed. If you are using older versions, please update SobiPro and its applications to the most recent versions!

  1. Steve Hess
  2. Community Area
  3. Sunday, 15 May 2016
I am running Sobipro 1.1.13 (it's not broken) and starting less than a week ago, my map module no longer shows the cluster circles around the quantity of markers. I tried turning off clustering (it reverted to individual markers) and turning it back on, but it still doesn't make the circles reappear. Please see attachment.

The weird thing is that there hasn't even been a Joomla update during this time. Nothing changed on my site immediately before this change occurred.

Any thoughts? Something on the Google maps side/js?
Attachments (1)
Accepted Answer
Accepted Answer Pending Moderation
0
Votes
Undo
Hello,

Update of the SP-GeoMap Module released

As because of the latest removal of the cluster marker project from googlecode.com, we now load the images locally to avoid problems with cluster images in future.
  1. more than a month ago
  2. Community Area
  3. # Permalink
Accepted Answer Pending Moderation
0
Votes
Undo
Thank you! I have been reticent to update SopiPro because first of all, it's not broken the way it sits....or wasn't until this clustering issue. I updated SP core once a while back and it totally messed up my styling. With the addition of all things bootstrap 3, I'm concerned that my styling or functionality will break or at minimum will require lots of effort to retain, which I don't have time to do right now.

At least I know the answer though! Thank you!
  1. more than a month ago
  2. Community Area
  3. # 1
Accepted Answer Pending Moderation
0
Votes
Undo
I have the same issue. Marker Clusterer icons are gone because they link to the old repository. So changing the URL from https://google-maps-utility-library-v3.googlecode.com/svn/trunk/markerclustererplus/images/m to https://raw.githubusercontent.com/googlemaps/js-marker-clusterer/gh-pages/images/m has to solve the issue.

I tried to change it here modules/mod_sobipro_geomap/install/markerclusterer.js but it did not help. The issue remains. Perhaps, we need to make change in some other file? Please tell me if someone has already solved this issue.
  1. more than a month ago
  2. Community Area
  3. # 2
Accepted Answer Pending Moderation
0
Votes
Undo
...
  1. more than a month ago
  2. Community Area
  3. # 3
Accepted Answer Pending Moderation
0
Votes
Undo
Hello. I made the same changes that Olekssi without success, there are probably one or a few lines to change but I do not know where. Even if it comes from Google, a little help would be nice and professional.
Sure, I will not pay again a subscription for this issue, it's a shame..
  1. more than a month ago
  2. Community Area
  3. # 4
Accepted Answer Pending Moderation
0
Votes
Undo
Ok... Take the file markerclusterer-uncompressed.js (module mod_sobipro_geomap_install)
Remplace MarkerClusterer.IMAGE_PATH by "https://rawgit.com/googlemaps/js-marker-clusterer/gh-pages/images/m";
Copy source code in a javascript compression tool (as jscompress .com) and save the file in
components/com_sobipro lib/js/markerclusterer.js -> ;)
  1. more than a month ago
  2. Community Area
  3. # 5
Accepted Answer Pending Moderation
0
Votes
Undo
That worked Kristine? Do you have a site I can look at that this worked on?

I ask because I basically did all of this except for the compress part. I even removed the compressed version of the file....still didn't work. It always tried to call the original Googecode URL.
  1. more than a month ago
  2. Community Area
  3. # 6
Accepted Answer Pending Moderation
0
Votes
Undo
I tried this and it worked!!!! Yay!!!
  1. more than a month ago
  2. Community Area
  3. # 7
Accepted Answer Pending Moderation
1
Votes
Undo
Yay !!! I'm glad :) :) :)
  1. more than a month ago
  2. Community Area
  3. # 8
Accepted Answer Pending Moderation
0
Votes
Undo
Kristine, I was trying to mod your solution to pull the images from my local server, but have been unsuccessful. Does it require HTTPS?
  1. more than a month ago
  2. Community Area
  3. # 9
Accepted Answer Pending Moderation
1
Votes
Undo
I'm sorry Stephen, I don't know... I have not tried this and am not sufficiently expert about the google map API ..
  1. more than a month ago
  2. Community Area
  3. # 10
Accepted Answer Pending Moderation
0
Votes
Undo
You have already helped tremendously, thank you! I just don't know how long that site you used will be there! I figure using local images would be the better solution.
  1. more than a month ago
  2. Community Area
  3. # 11
Accepted Answer Pending Moderation
0
Votes
Undo
Unfortunately for some reason it does not work. Still refers to the old url. Any thoughts?
Attachments (1)
  1. more than a month ago
  2. Community Area
  3. # 12
Accepted Answer Pending Moderation
0
Votes
Undo
Did you read Kristine's post carefully? The newly compressed file has to be in the component subfolder.I had to read it a couple times before I realized it was NOT in the module folder.
  1. more than a month ago
  2. Community Area
  3. # 13
Accepted Answer Pending Moderation
1
Votes
Undo
Stephen, I read carefully, but thank you for your reply. There was problem with cache in CloudFlare. Now everything is working great. Thank you Kristine for this solution. I think it will be useful for many our collegues.
  1. more than a month ago
  2. Community Area
  3. # 14
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

This forum may be used only to ask questions and give answers for SobiPro component and its applications. Advertising, commercial questions or statements, and sharing of software of any kind is not allowed. If you need professional support, feel free to join the club and use the ticket system for subscribers. If you have membership-related questions, please use the contact form.
By using this forum, you accept the standard terms of netiquette on forums as you can find for example here.

to Top