Support Area

As a SobiPro club member you will get ticket support in the support area.
For our former club members we provide a free of charge forum to ask other members.

Powerful search

The SobiPro Search is one of the features that make SobiPro a very powerful tool for site visitors. Almost each field can be configured to show up in the search form.

One for all

With SobiPro you can create as many directories and any other content types on your site as you need with only one single SobiPro component installation.

Responsive

Bring your directory with you on any device. Due to Bootstrap powered templates, you can show your content on any device out of the box

 

Resolved
0 votes
Accessing Google Maps Platform without an account (an account requires a billing profile and a valid API key)

What will begin happening on June 11th
In June 2016, we communicated that we would stop supporting keyless usage (any request that doesn’t include an API key or Client ID). More recently, on May 2, 2018, we announced that beginning on June 11, 2018, keyless Maps API calls will return low-resolution maps watermarked with “for development purposes only”, and keyless calls to other APIs will return an error.
Tuesday, June 05 2018, 03:17 AM

Accepted Answer

Wednesday, October 17 2018, 08:22 AM - #Permalink
Resolved
0 votes
Hopefully SobiPro will have a real fix soon.


Our SP-GeoMap module and the SP-GeoMap field are Google API-key compatible. Depending on the version you have, it may be necessary to update the applications. Otherwise you have to setup the application correctly.

Sigrid Suski
The reply is currently minimized Show
Responses (10)
  • Accepted Answer

    Tuesday, June 05 2018, 03:12 PM - #Permalink
    Resolved
    0 votes
    It's up to you to get an API key from Google. We do not provide Google API keys.

    Sigrid
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, June 05 2018, 09:54 PM - #Permalink
    Resolved
    0 votes
    I already have a key.

    Its how to implement it into sobipro geomap is what I'm asking.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, August 29 2018, 06:39 PM - #Permalink
    Resolved
    -1 votes
    Hello Garry,

    are you already with the problem? I have now received a similar error message. How it looks like, should I pay extra for using the Geomap module?

    Then you should offer the Geomap module for free. A four-month membership for my extensions of SobiPro currently costs me 95 EUR.

    Greetings Tommy
    Attachments:
    The reply is currently minimized Show
  • Accepted Answer

    Friday, August 31 2018, 05:36 AM - #Permalink
    Resolved
    0 votes
    I have the basic geomap field and the Google API key. I entered the key info in the geomap configuration. Still unable to display thdfasfasdfe map.
    The reply is currently minimized Show
  • Accepted Answer

    Tuesday, September 25 2018, 04:41 PM - #Permalink
    Resolved
    0 votes
    The same here. I do have a Google API Key but it still displays the message. :-(
    Attachments:
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, September 26 2018, 09:37 AM - #Permalink
    Resolved
    0 votes
    I have exactly the same problem ... Can anyone help?
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, September 26 2018, 11:09 AM - #Permalink
    Resolved
    0 votes
    When I got that message that the ma would not display correctly and "for developer use only" across it I had to add the line of script under step 2 from this page to my template head Title

    (I did not need to add my api anywhere else, the main maps then worked that show all the markers but not ones on individual entries)
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, September 27 2018, 03:23 PM - #Permalink
    Resolved
    0 votes
    Finally I found the solution! In the GeoMap Module you have to fill in the right Google API URL:

    https://maps.google.com/maps/api/js?sensor=true&key=YOUR_API_KEY


    See also https://www.sigsiu.net/support/sp-geomap-module/7802-no-entry-field-for-api-key-in-geo-map-module
    Attachments:
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, October 04 2018, 03:53 PM - #Permalink
    Resolved
    0 votes
    Changing the link in my existing GeoMap module from:

    https://maps.googleapis.com/maps/api/js?key=

    to:

    https://maps.google.com/maps/api/js?sensor=true&key=

    made no difference for me, I still have the same error or my site (http://tournamart.com/). I don't want to pay for a new version of the module until I know if doing so will actually fix this problem or not. Will it?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, October 05 2018, 04:33 PM - #Permalink
    Resolved
    0 votes
    I heard back from Google support on this and here's what they told me:
    ------
    If you open the dev tool and check the Console tab you will see the error is due to a missing API key in your script.
    Keyless usage of Maps API has been deprecated since the 16th of September.
    This is the script that fetches the API in that web page:

    <script src="http://maps.googleapis.com/maps/api/js?sensor=true&libraries=places" type="text/javascript"></script>


    You need to include the API key there and remove the sensor parameter that is no longer required.
    Here is an example:
    https://developers.google.com/maps/documentation/javascript/examples/map-simple

    <script src="/https://maps.googleapis.com/maps/api/js?key=your_api_key&callback=initmap"
    async defer></script>

    ------

    I did see the error message they mentioned in the Console and when I looked at the page source sure enough I found this:

    ------
    	.SpGeoMapMod img { max-width: none; }
    </style>
    <script src="http://maps.googleapis.com/maps/api/js?sensor=true&libraries=places" type="text/javascript"></script>

    <script type="text/javascript" src="http://tournamart.com/components/com_sobipro/var/js/xxx.js"></script>
    <script type="text/javascript">

    ------

    and the URL I had specified in the SobiPro GeoMap Module's Google API URL field is missing. Just to see if it EVER showed up I changed that field to https://maps.google.com/fluffy and then looked at my page source and found that that DID show up but AFTER the above googleapis url rather than replacing it:

    ------
    	.SpGeoMapMod img { max-width: none; }
    </style>
    <script src="http://maps.googleapis.com/maps/api/js?sensor=true&libraries=places" type="text/javascript"></script>

    <script type="text/javascript" src="/https://maps.google.com/fluffy"></script>
    <script type="text/javascript" src="http://tournamart.com/components/com_sobipro/var/js/xxx.js"></script>
    <script type="text/javascript">

    ------

    So then I changed it to what the Google folks told me to use, https://maps.googleapis.com/maps/api/js?key=YOUR_API_KEY&callback=initMap, and looked at the source again and we were back to the original situation where that URL did not show up.

    That told me that SobiPro was filtering out URLS that contain the googleapi text so I installed URL redirecting software (ReDJ Community from http://www.selfget.com/downloads/category/3-redj.html) on my site and created a dummy URL (http://tournamart.com/sobimapapi) that forwards to the real URL with my API key (https://maps.googleapis.com/maps/api/js?key=YOU_API_KEY&callback=initMap) and put that dummy URL in the SobiPro GeoMap Module's Google API URL field and now my map displays. I had to set Decode URL to yes and every other option to no in the ReDJ list of options for this redirect.

    If you don't have redirection software on your site you can do the same using http://tinyurl.com or similar but then you'd have to update your Google Cloud Platform permissions to allow tinyurl.com to use your API key (assuming your currently have it restricted to just your sites IP address).

    So, if you get a "Something went wrong" displayed on your map and a "Referer Not Allowed" error in the Console:
    Google Maps JavaScript API error: RefererNotAllowedMapError
    https://developers.google.com/maps/documentation/javascript/error-messages#referer-not-allowed-map-error
    Your site URL to be authorized: http://tournamart.com/

    when trying to display your map then click on the URL in the error or go to https://console.cloud.google.com/, log in, select your project and Enable APIs -> Maps JavaScript API -> Credentials -> Click on your key name -> change Application restrictions to None (or do whatever else you feel is appropriate to allow those requests).

    Hopefully SobiPro will have a real fix soon.

    PS the "=initMap" at the end doesn't seem to be necessary and causes an error message in the Console window.
    The reply is currently minimized Show
Your Reply

This forum may be used only to ask questions and give answers for SobiPro component and its applications. Advertising, commercial questions and sharing of software of any kind is not allowed. If you need professional support, feel free to join the club and use the ticket system for subscribers. If you have membership-related questions, please use the contact form.
By using this forum, you accept the standard terms of netiquette on forums as you can find for example here.

to Top