Skip to content
You are here: Home
Requirements

Requirements for SobiPro.
In order to use SobiPro on your server there are some requirements which have to be met.

Minimum requirements

In case these requirements are not met, SobiPro won't work at all.

SobiPro 1.1:
  • Joomla! 2.55 or 3.2
  • HTML5 and CSS3 compatible browser
  • PHP 5.3.9
SobiPro 1.0:
  • Joomla! 1.5 (at least 1.5.20) or 2.55
  • PHP 5.2
SobiPro 1.0 and 1.1:

Highly recommended settings

In case these requirements are not met, some functionality may be limited or disturbed.

Additional recommended settings

  • Joomla! FTP Layer disabled
  • PHP Register Globals disabled
  • A Joomla! template able to display Joomla! System Messages. SobiPro relies on these messages when reporting certain errors and notifications, so not being able to see them might interfere in SobiPro's correct operation.


1) MySQL 6 is not supported

2) Joomla! 1.5 and 2.5/3.0/3.1 in the default installation use always utf-8 encoding and database collation. It is not recommended to change this setting to other than utf-encodings. However, it may be sometimes useful to change the database collation from "utf8_general_ci" to a more appropriate setting for your language. For example to "utf8_polish_ci" for Polish language or to "utf8_roman_ci" for German or French.
It is especially useful for languages with special non-Latin letters as sorting operations in SobiPro are done by the database.

3) Some providers seem to provide this functionality within the PHP configuration, but at the same time outgoing connections are blocked on the firewall or do not allow CURL for SSL URLs.
Please ensure that this functionality is enabled and also that it is indeed possible to use it.

4) SQLite can be supported directly via the SQLite extension or through the PHP Data Objects extension.

5) Regarding Joomla! 1.6/1.7, while SobiPro 1.0 should work for 1.6.4 or above we're not providing support for those versions anymore as they reached their EOL long ago. SobiPro 1.1 is not meant to be used on Joomla! 1.5/1.6/1.7!

 
Ads/Anzeige
Become a SobiPro Club Member