Support Area

SobiPro club members with an active subscription are entitled to get ticket support in the support area. For our former club members we provide a free of charge forum to ask other members. If you need professional support with fast answers, feel free to join the club.


Update SobiPro and its applications to the most recent version before reporting a problem!

We are continously improving SobiPro and its applications, fixing bugs and making working with them more easy. Still we see that some users report problems for older versions. Mostly they are already fixed. If you are using older versions, please update SobiPro and its applications to the most recent versions!

  1. Sean Dettmer
  2. Community Area
  3. Wednesday, 25 January 2017
Hello SobiPro World,
I see the above issue on your demo site https://demo.sobi.pro/search
I'm sure the three rectangles should read All Words, Exact Words and Any Words.
Thanks,
Dettmer
Accepted Answer
Accepted Answer Pending Moderation
0
Votes
Undo
This worked for me (reply from sigsiu to a ticket I had opened). Sorry about the formatting, the only way I could get this to appear without the XSL being interpreted was to remove every leading `<` :(

Could you please try to edit search/view.xsl template and in the part:

xsl:if test="count( /search/fields/phrase/* )">
div class="form-group">
label class="col-sm-3 control-label" for="sp-search-phrases">
xsl:value-of select="/search/fields/phrase/label" ></xsl:value>
/label>
div class="col-sm-9 sp-search-phrases">
div class="btn-group" data-toggle="buttons">
xsl:for-each select="/search/fields/phrase/data/*">
label class="btn btn-default">
xsl:if test="./input/@checked = 'checked'">
xsl:attribute name="class">btn btn-default active</xsl:attribute>
/xsl:if>
xsl:copy-of select="./input" ></xsl:copy>
xsl:value-of select="./label" ></xsl:value>
/label>
/xsl:for-each>
/div>
/div>
/div>
/xsl:if>



and change line:

xsl:value-of select="./label" ></xsl:value>

to:

xsl:value-of select="." ></xsl:value>
  1. more than a month ago
  2. Community Area
  3. # Permalink
Accepted Answer Pending Moderation
0
Votes
Undo
I have that issue on my site (http://tournamart.com/). Anyone know a fix?
  1. more than a month ago
  2. Community Area
  3. # 1
Accepted Answer Pending Moderation
0
Votes
Undo
Same three squares on my site
  1. more than a month ago
  2. Community Area
  3. # 2
Accepted Answer Pending Moderation
0
Votes
Undo
Thanks Edward
Buttons now fixed
  1. more than a month ago
  2. Community Area
  3. # 3
Accepted Answer Pending Moderation
0
Votes
Undo
Thank you very much for sharing that fix with us Edward.

I've decided to remove these buttons from my search and thought i would share it.
Please see images below for the lines that I've removed from search/view.xsl.

I would also like to remove the County select drop down from my search form. If anyone has any idea please let me know.

Cheers,
Dettmer
Attachments (2)
  1. more than a month ago
  2. Community Area
  3. # 4
Accepted Answer Pending Moderation
0
Votes
Undo
Hi Gary
Can you clarify where to find the view.xsl file so I can modify it?

thanks

Barry
  1. more than a month ago
  2. Community Area
  3. # 5
Accepted Answer Pending Moderation
0
Votes
Undo
Barry Hill wrote:

Hi Gary
Can you clarify where to find the view.xsl file so I can modify it?

thanks

Barry

I found it on this path, on my file it is already applied, but still getting the 3 empty square buttons

components/com_sobipro/usr/templates/yourappname/search
  1. more than a month ago
  2. Community Area
  3. # 6
Accepted Answer Pending Moderation
0
Votes
Undo
Gerardo Alvarez wrote:

Barry Hill wrote:

Hi Gary
Can you clarify where to find the view.xsl file so I can modify it?

thanks

Barry

I found it on this path, on my file it is already applied, but still getting the 3 empty square buttons

components/com_sobipro/usr/templates/yourappname/search


My mistake, if you are using the sobipackages template the path is this one
components/com_sobipro/usr/templates/sobipackages/search/view.xls

In that file you will have to apply the correction mentioned by Eduard Morton at line 59

change line:

xsl:value-of select="./label" >

to:

xsl:value-of select="." >

Already applied to my file and now the buttons are working fine
  1. more than a month ago
  2. Community Area
  3. # 7
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

This forum may be used only to ask questions and give answers for SobiPro component and its applications. Advertising, commercial questions or statements, and sharing of software of any kind is not allowed. If you need professional support, feel free to join the club and use the ticket system for subscribers. If you have membership-related questions, please use the contact form.
By using this forum, you accept the standard terms of netiquette on forums as you can find for example here.

to Top