Support Area

SobiPro club members with an active subscription are entitled to get ticket support in the support area. For our former club members we provide a free of charge forum to ask other members. If you need professional support with fast answers, feel free to join the club.


Update SobiPro and its applications to the most recent version before reporting a problem!

We are continously improving SobiPro and its applications, fixing bugs and making working with them more easy. Still we see that you report problems for old versions of SobiPro or its applications. Mostly they are already fixed. If you are using an older version of SobiPro, please check the changelog list if your problem is solved in the meantime. It is also worth to read all the fixed issues in our tracker. If you think that this is too much work, simply update SobiPro to the most recent version!

  1. Reinhard Chmiela
  2. Community Area
  3. Friday, 02 February 2018
I found this Fatal Error:
Declaration of SPEntryView::display() must be compatible with SPFrontView::display($o = NULL) in D:\www_local_1\urlaubinmv_joomla\components\com_sobipro\lib\views\entry.php on line 29

I changed line 29:
public function display() to public function display( $o= null )

Now it runs.:)
Accepted Answer Pending Moderation
0
Votes
Undo
Thank-you Reinhard for leading me to what I needed.

I am running Sobipro 1.4.11 on Joomla 3.9.3. With php 7 it was fine, but on php 7.1 or 7.2 the admin entry fields page was blank (other errors too).

In:
components\com_sobipro\lib\views\entry.php

I changed line 29:
public function display( $o = null )
to
public function display( $o= null )

And now can see my entry fields page again.
  1. more than a month ago
  2. Community Area
  3. # 1
Accepted Answer Pending Moderation
0
Votes
Undo
Hi

Could you please describe this problem with more details? What do you mean by admin fields page? You refer to fields manager in administrator area? The only known problem for me in this moment is error page during adding new field when there is no field with fid=1. It is already reported here with fix file:
https://code.sigsiu.net/Sigsiu.NET/SobiPro/issues/148

Regards
Sikor
  1. more than a month ago
  2. Community Area
  3. # 2
Accepted Answer Pending Moderation
0
Votes
Undo
Hi Sikor,

Thanks for replying. Yes I meant a blank page in the fields manager in administrator area with php 7.2.16. This is not the error you described but I did test the fix that you mentioned just in case.

Today I updated Joomla to 3.9.4 and got a blank page with php 7.2.16, but this time I am able to run php 7.1.27 and see the page properly.

Screenshots attached.

I have Sobipro 1.4.11 but lots of my Sobi applications are needing an update when I am next able to renew my subscription.

Regards
Suzanne
Attachments (2)
  1. more than a month ago
  2. Community Area
  3. # 3
Accepted Answer Pending Moderation
0
Votes
Undo
I can't recreate your issue at my test sites. Could you please maximize debug level in the SobiPro (to all errors warnings and notices), set display errors to yes, then maximize debug in the Joomla! to development level and check if there appear any error? You can also try same with enabled Joomla! debug option.

Regards
Sikor
  1. more than a month ago
  2. Community Area
  3. # 4
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

This forum may be used only to ask questions and give answers for SobiPro component and its applications. Advertising, commercial questions and sharing of software of any kind is not allowed. If you need professional support, feel free to join the club and use the ticket system for subscribers. If you have membership-related questions, please use the contact form.
By using this forum, you accept the standard terms of netiquette on forums as you can find for example here.

to Top